anyone else having issues? - Car Audio Classifieds!
Car Audio Classifieds!  

Go Back   Car Audio Classifieds! > Vendors > (DC)

(DC) DC Audio's Online Forum


Notices

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-19-2011, 10:09 AM
New CACO Member
 
Activity Longevity
0/20 16/20
Today Posts
0/11 sssssss87
Location: IL
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (3)
Feedback Score: 3 reviews
Default anyone else having issues?

So I bought a level 4 15 with the 5 softparts 4 8's and 3 shirts. It got the shirts today after a month and half. Ill start with the 8's. I hooked up 2 of them to 720 rms at 2 ohm on my sundown with everything turned all the way down and they started smoking and smelling but they still work as of now. So i built the box for the 4 of them and got them hooked up in 1ohm on a sax1200 with everything still turned down and the 2 are still stinking and smoke a little.

Now the 15 i had it hooked up to my friends hifonics brutus 1200 into a 1ohm load. again with everything turned down. I noticed a scratching sound after just a few mintues of playing. Pulled the sub out of the box and the coil was rubbing. Called Dc for 2 days before someone finally answered the phone. I got the recone for it covered under warranty. But my 1st comp is the 26th and I dont have the sub I paid good money for.

I have never had such issues with any other subs I have had. I ran Jl 15w0v2 for along time on double the power it was rated for and it still worked great before I sold it to buy DC.
Just really wondering if anyone else has had problems like this. As of right now Im not extremely happy with this purchase outcome.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-19-2011, 10:12 AM
Elite Member
 
Activity Longevity
0/20 19/20
Today Posts
0/11 sssss8594
Location: pa
Thanks: 181
Thanked 163 Times in 142 Posts
iTrader: (55)
Feedback Score: 55 reviews
Default

u may have just gotten a fluke batch...i dont have any issues with my lvl 3s playing...however, wen i got them, they were sitting at 3.0 ohm per coil
__________________
Authorized Dealer for Audio Legion


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Enclosures

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message
  #3  
Old 03-19-2011, 10:23 AM
New CACO Member
 
Activity Longevity
0/20 16/20
Today Posts
0/11 sssssss87
Location: IL
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (3)
Feedback Score: 3 reviews
Default

Quote:
Originally Posted by fyerbyrd22 View Post
u may have just gotten a fluke batch...i dont have any issues with my lvl 3s playing...however, wen i got them, they were sitting at 3.0 ohm per coil
i have no idea what my coils are sitting at. I dont have the meter to test them. I ordered d2 for all of them so i assumed thats what they are sitting at
Reply With Quote Quick reply to this message
 
  #4  
Old 03-19-2011, 01:25 PM
New CACO Member
 
Activity Longevity
0/20 16/20
Today Posts
0/11 sssssss87
Location: IL
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (3)
Feedback Score: 3 reviews
Default

im guessing im the only one with this issue?
Reply With Quote Quick reply to this message
  #5  
Old 03-19-2011, 01:50 PM
NoPh33rRaCiNg's Avatar
I <3 ( . )( . )'s
 
Activity Longevity
0/20 20/20
Today Posts
0/11 sssss3010
Location: Kent, WA
Age: 30
Thanks: 250
Thanked 48 Times in 39 Posts
iTrader: (29)
Feedback Score: 29 reviews
Default

I've ordered (4) Lvl 4/Lvl 5 Coil 15's, (4) Lvl 4 XL 15's, and (2) Lvl 2 8's and never had a single issue.
__________________
Team DC Audio : Team NWSPL : Team Shok
02 Tahoe - (1) 15'' XL, Shok II, Shok 1/0
03 S10 (in progress) - (3) 15'' Lvl5's, (2) DC 5k's, lots of Shok 1/0

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message
  #6  
Old 03-19-2011, 02:29 PM
New CACO Member
 
Activity Longevity
0/20 16/20
Today Posts
0/11 sssssss87
Location: IL
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (3)
Feedback Score: 3 reviews
Default

i dunno what the heck the problem is then. My buddy just brought his 500 watt amp over and as soon as we hooked it up it blew. Coil is black from the top to not quite halfway down. Wont move or anything.
Reply With Quote Quick reply to this message
  #7  
Old 03-19-2011, 02:59 PM
Droppin' HZ Car Audio
 
Activity Longevity
0/20 18/20
Today Posts
0/11 sssss1596
Location: Virginia
Thanks: 8
Thanked 123 Times in 94 Posts
iTrader: (26)
Feedback Score: 26 reviews
Default

Ive never had any problems with any of mine. One thing to consider though is just because you have your gains all the way down doesnt mean you arent getting full power out of the amp. The gain setting depends on the RCA input voltage. It is not a power knob. I would invest in a good oscope and learn how to use it to set your amps.
Reply With Quote Quick reply to this message
  #8  
Old 03-19-2011, 07:19 PM
Elite Member
 
Activity Longevity
0/20 19/20
Today Posts
0/11 sssss8594
Location: pa
Thanks: 181
Thanked 163 Times in 142 Posts
iTrader: (55)
Feedback Score: 55 reviews
Default

Quote:
Originally Posted by pitbull1078 View Post
i dunno what the heck the problem is then. My buddy just brought his 500 watt amp over and as soon as we hooked it up it blew. Coil is black from the top to not quite halfway down. Wont move or anything.
which sub??...no sub has ever nor will ever blow from being underpowered
__________________
Authorized Dealer for Audio Legion


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Enclosures

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message
  #9  
Old 03-20-2011, 01:02 AM
The A Team's Avatar
Active Member
 
Activity Longevity
0/20 20/20
Today Posts
0/11 ssssss817
Age: 44
Thanks: 0
Thanked 11 Times in 7 Posts
iTrader: (5)
Feedback Score: 5 reviews
Default

I am speaking for every manufacturer out there with this comment..... I will bet 95&#37; of all failures are due to USER ERROR!!!

People will hardly ever admit it but from my years of competing and the # of subs/amps i have personally used and my local customers experiences this statement is true. I find people are to quick to jump on the blame game when they have made a small mistake somewhere along the lines of the install or in wiring, tuning or what have you. But everyone thinks no i know what i am doing..... Face it we all make mistakes, i have made many and it has cost me. Sometimes the mistakes are not so easy to identify, and you are led to believe you did everything correctly..... but little do you know there is a issue hiding in there.

I have seen local guys do stuff like putting the wrong coils in series when wiring series/parallel and subs getting so hot you couldnt touch them. Also guys strapping amps (correctly even) yet running into phase issues causing subs to fail. Seen enclosures that were so poorly built they were breaking baskets because of baffle flex. Seen relays wired incorrectly blowing up amps on turn on. Poor grounding/ improper fuses...... In just about ever case the person experiencing the problem insisted they had done everything correct!
__________________
I play lower, louder, and longer thanks to
DC Audio
&
Stetsom amplifiers
Reply With Quote Quick reply to this message
  #10  
Old 03-22-2011, 08:45 AM
Elite Member
 
Activity Longevity
0/20 20/20
Today Posts
0/11 ssssss621
Location: pa
Age: 49
Thanks: 4
Thanked 4 Times in 4 Posts
iTrader: (3)
Feedback Score: 3 reviews
Default

Quote:
Originally Posted by The A Team View Post
I am speaking for every manufacturer out there with this comment..... I will bet 95% of all failures are due to USER ERROR!!!

People will hardly ever admit it but from my years of competing and the # of subs/amps i have personally used and my local customers experiences this statement is true. I find people are to quick to jump on the blame game when they have made a small mistake somewhere along the lines of the install or in wiring, tuning or what have you. But everyone thinks no i know what i am doing..... Face it we all make mistakes, i have made many and it has cost me. Sometimes the mistakes are not so easy to identify, and you are led to believe you did everything correctly..... but little do you know there is a issue hiding in there.

I have seen local guys do stuff like putting the wrong coils in series when wiring series/parallel and subs getting so hot you couldnt touch them. Also guys strapping amps (correctly even) yet running into phase issues causing subs to fail. Seen enclosures that were so poorly built they were breaking baskets because of baffle flex. Seen relays wired incorrectly blowing up amps on turn on. Poor grounding/ improper fuses...... In just about ever case the person experiencing the problem insisted they had done everything correct!
Very well said!!!
__________________
TEAM DC AUDIO
TEAM COMPETITION AUDIO
Two DC Power 270 XP's at 15.1 Volt's
One XS Power S3400
Four XS Power D3100's
One DC 9K
16 DC Lvl 2 8's
1997 Jeep Wrangler Soft Top
Boyd hands out demos like snickers on Halloween =]
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Car Audio Classifieds! forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Location
Where you live
Level of Car Audio Knowledge
What's your level of car audio?

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
amp issues hdman87 General Car Audio Discussion & Questions 4 12-15-2010 07:51 AM
Ear issues anyone? Silenkiller General Car Audio Discussion & Questions 29 06-20-2010 03:47 PM
Aol issues? tc3k101 Off Topic Chat 16 02-26-2010 07:35 PM
About RD CS issues BigC-Expo Off Topic Chat 87 11-18-2009 12:07 AM
HID Issues NoPh33rRaCiNg General Automotive Chat 21 09-21-2009 06:41 AM

» Amps
A/d/s/
Advent
Alphasonik
Alpine
American Bass
ARC Audio
Atomic
Audio Art
Audio Gods
Audiobahn
Audiocontrol
Audiopipe
Audison
Aura
Autotek
Avionixx
Bazooka
Beyma
Blaupunkt
Boss
Boston Acoustics
Bravox
Cadence
Cascade (CAE)
CDT Audio
Cerwin Vega
Clarion
Clif Designs
Concept
Coustic
Critical Mass
Crossfire
Crunch
DB Drive
DC Audio
DC Power
DEI
Denon
Diabolo
Diamond
Digital Designs
Directed
DLS
Dual
DYnamat
Dynaudio
Earthquake
Eclipse
Elemental Designs
ESX
Eton
Farenheit
Fi Car Audio
Fix My Speaker
Focal
Fusion
Genesis
Ground Zero
Hafler
Helix
Hertz
Hifonics
Hushmat
Image Dynamics
Infinity
Interfire
JBL
Jensen
JL Audio
JVC
Kenwood
Kicker
Knu Konceptz
Kole Audio
Kove Audio
Lanzar
Lightning Audio
Linear Power
MA Audio
Magnat
Marantz
Massive Audio
MB Quart
McIntosh
Memphis
Metra
MMATS
Mobile Authority
Morel
MTX
Nakamichi
Niche Audio
O2 Audio
Ohio Generator
Optima
Orion
Oxygen Audio
OZ Audio
PG Audio
Phase Linear
Phoenix Gold
Pioneer
Polk
Power Acoustik
Powerbass
Powermaster
Precision Power
Profile
Pyle
Pyramid
RadioShack
Rainbow
Rampage
RE AUdio
Rockford Fosgate
Scanspeak
Scosche
Seas
Sony
soundstream
Sparkomatic
SPL Dynamics
Stinger
Sundown Audio
Swiss Audio
Targa
TC Sounds
TREO Engineering
TRU
Tsunami
Ultimate
US Acoustics
US Amps
Velodyne
Vifa
Viper
Visonik
Xtant
Zapco
Zed Audio
Powered by vBadvanced CMPS v3.2.3
Links
Amp Guts
amplifier, amp guts, ampguts, car audio classifieds, speakers and subs for sale with listings of 12 volt sound systems. Security systems for sale for aftermarket car audio equipment with amplifier and amps for sale
Car Audio Forum
car audio forum, moble audio, car stereo, wholesale car audio, 12 volt, with, amplifier, amp, subwoofer, sound quality, buy car audio, and sell automotive stereo systems for cars
Car Audio Sound Quality Forum
Sound QUality science based car audio forum, amplifier, subs and speaker design, fabrication help, sound systems forum, aftermarket car audio website for sound quality.
Car Stereo Forum
DIYMA car audio stereo forum for 12 volt car audio subwoofer and amplifier systems that have sound quality with wholesale car audio products.


All times are GMT -5. The time now is 09:48 PM.


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.