Car Audio Classifieds! banner
1 - 17 of 17 Posts

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #1 ·
OKay I was playing one of my TC-3000's on phil collins in the air tonight and when it when down to the sweep I heard a loud ppping noise and I quickly shut it off then I played a different song at low levels and it made a buzzing noise then I went back there to check the sub and it has slight coil rub its not that bad. Does anybody think that if I tale off the top assembly and straighten out the coil that I can get it working if I'm careful?
 

·
NOT LOUDER THAN YOU :(
Joined
·
7,335 Posts
you have the qca top assembly? might be loose?
 

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #4 ·

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #5 ·
you have the qca top assembly? might be loose?
Yup and they shouldn't be I'll double check but I think it was the sub bottoming out.
 

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #6 ·
Bump! Need help!
 

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #8 ·
Have you removed the top assembly to check out the coil?
Nope haven't had the time yet. I've had to go to a funeral and all this other crap today so I was kinda busy but I'll get around to it.
 

·
Registered
Joined
·
5,387 Posts
Someone is going to get the banhammer again....

OP, take off the top and check it out. Its pretty hard for a bunch of people on a forum to trouble shoot something we can't hear especially without any solid evidence.
 

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #11 ·
Someone is going to get the banhammer again....

OP, take off the top and check it out. Its pretty hard for a bunch of people on a forum to trouble shoot something we can't hear especially without any solid evidence.
Thanks will do man once I get the time to do it. I'll take pics too.
 

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #12 ·
I fixed this. It wasn't the coil being damaged it was the bolts coming loose and then becoming slightly misaligned. Thank god. I'm really glad that I didn't bottom this thing out.
 

·
Banned
Joined
·
1,245 Posts
Discussion Starter · #14 ·
Good, but just be a lesson learned about putting the woofer to the extremes.
Yeah and be a lesson to use blue loc tite lol
 

·
Premium Member
Joined
·
3,460 Posts
use the 4 side bolts also... i never had this issue and i ONLY used the weak 4 side bolts... u have 6 huge bolts so this shouldnt be happening

loctite or ca glue is usually applied for this specific reason


playing that sine wave phil collins is not good for any sub, especially going down so low while ur tuned at 30hz.... i wouldnt play lower than 25hz, that sub gets moving some serious business below tuning
 
1 - 17 of 17 Posts
Top