Car Audio Classifieds! banner
1 - 14 of 14 Posts

·
Registered
Joined
·
462 Posts
Discussion Starter · #1 ·
On January 11, 2011, I ordered 2 WMD2 10” subs. I had a snafu with my credit card, and wasn’t able to order both subs. I called PAP that following Monday, and they allowed me to purchase the second sub for the sale price even though it was over. I was grateful for that gesture, and let them do their magic. After 2 weeks of no updates from them, I called their facility and asked for an update. About an hour after leaving a voicemail, they called me back and told me the parts needed to build the subs were out-of-stock, and it would take longer to build them. Ok, no problem, I thought, until another 1.5 weeks pass, and I call back and leave another voicemail. I received an email the following day which stated that they just received the needed parts, and would be building and shipping them at the end of the week. Finally, after 4 weeks of waiting, I received a tracking number on February 7th, and noticed that PAP shipped the subs via USPS Parcel Post. Two days later, the sub is accepted by their local USPS post office, and then on February 15, I receive the subs.
Upon removing the sub from the packaging, I inspected and noticed no physical damage to either of the subs. I hooked them up in my truck to test and as soon as the subs started to move, to my surprise, one of the subs started to show coil rub. I played the sub on several different songs, but the coil rub still showed and didn’t go away. I was hoping it would go away after a couple minutes of use, but no luck there.
I immediately called PAP, but to no surprise, no one picked up. I left another voicemail, and waited. The next afternoon, I got a call and was told that they were out of the office, but the best way was to email them. I had previously emailed them before the call, so I knew just to wait longer. The following day I received an email from Paul stating to check for physical damage to the basket and if so, I would have to go through my local USPS store to get my money back. However, when they insured the sub, they didn’t even insure for the full price I paid for it. He also stated, if it was a warranty issue, I would have to send it back, and they would repair/replace it to THEIR discretion, and I would HAVE to pay for shipping it both ways. I responded back saying, why should I have to pay to ship it back and forth when out-of-the-box, it had coil rub from the way it had been built. I also told them, that they should pay for shipping considering they overcharged me to ship the subs an extra $60 via USPS PARCEL POST. He then emailed me back stating they don’t cover shipping costs and when they “qc’d” the sub, it was fine.
I don’t think it’s fair how they were treating me as a customer, and wanted to inform my fellow audio enthusiasts how their business practices are. Upon further research, Pierce Audio Products, Inc. isn’t even listed anywhere on the Better Business Bureau’s accredited company’s site. I filed a claim through their website anyways, and will wait until I get another response from Paul. I don’t think it’s unreasonable that I expect a brand new sub with coil rub to be fixed free of charge by the company who should also pay for shipping both ways. I’m trying to work with them, but they seem unreasonable on their business practices; I just want my subs to be fixed the proper way.
 

·
Premium Member
Joined
·
7,568 Posts
yup. thats peirce. i attempted to buy parts from them and got a run around before i even paid for anything. i got 3 different stories in 4 emails.

thanx for the heads up man. :thumbsup:
 

·
Banned
Joined
·
368 Posts
I know it wont help but I emailed paul and told him his cs sucks and I will never run his product. Too bad though I kinda wanted to try their subs.
 

·
Premium Member
Joined
·
2,506 Posts
Hmmm I bought a wmd2 10" also. Was built and shipped in a week. Sat on my desk for a month and I sold it to a member here. He got it but it also had a problem so I pmed Paul on his forum and informed him he asked no questions just said have the Guy ship it back to them and he did and he had a brand new sub a week later. I've heard some bad things but the cs I got was pretty damn good lol I must have lucked out. They honored a warranty no questions asked even after the sub changed owners they even payed the shipping back to him
 

·
Premium Member
Joined
·
3,029 Posts
This doesn't surprise me the slightest
 

·
Registered
Joined
·
744 Posts
I remember the pap disaster over at roe about 2 years ago or so.. lol.. good luck with it.
damn that kinda sucks...they were one of the companies I was considering this year....any short summary of what happened? :confused:
 

·
Registered
Joined
·
8,409 Posts
that why i like to only buy things at a LOCAL store so when something like that happens you can go and talk to them face to face and get the problem fixed....that just sucks on your end.. sry to hear
 

·
Registered
Joined
·
267 Posts
Well the old servers went down and I have no way to prove what i say is true so I am not gonna stir up a hornets nest and not have proof, but if stratus aka rich was around or corey sundown ny or big mike were around hell or even kay i could back my story up... dj might know the story as well.. lets just say it was a hyped up crap storm and they left the forum over it... they didn't like some of the test results in the subwoofer challenge either.
 

·
Registered
Joined
·
152 Posts
Im running a wmd2R15. I got the motor from a friend but got a recone from pap. The customer service was average to me. Also seemed like they have nothing in stock lol. And had to twist his arm to give me glue that he said would come with my recone but didnt show up with it. Dont know how there build quality is past the recones. As for the sub i love mine and thinking about getting another one in the near future But will try to deal with pap themselves as little as possible.
 
1 - 14 of 14 Posts
Top